Dear forum users! In compliance with the new European GDPR regulations, we'd just like to inform you that if you have an account, your email address is stored in our database. We do not share your information with third parties, and your email address and password are encrypted for security reasons.

New to the forum? Say hello in this topic! Also make sure to read the rules.

Map Editor - Screen Flicker [Help]

Share questions and tutorials related to the map editor. Share you maps in the Superfighters Deluxe Custom Maps section.
Forum rules
By using the forum you agree to the following rules.
Post Reply
FutureWolf4
Meatbag
Posts: 4
Joined: Mon Aug 06, 2018 10:47 am

Map Editor - Screen Flicker [Help]

Post by FutureWolf4 » Mon Aug 06, 2018 12:59 pm

I just made an account to ask for some help regarding the map editor. While trying to make a new map for me and friends to play, I ran into a problem - the screen for the map editor starts to flicker (A black screen keeps popping up every second and then going back to the map). It's not a problem with the game itself, because while testing a map, it works fine but when I get back to the map editor it starts to bug out.

Does anyone know any way to fix this?
0 x

User avatar
Gurt
Lead Programmer
Lead Programmer
Posts: 1326
Joined: Sun Feb 28, 2016 3:22 pm
Title: Lead programmer
Started SFD: Made it!
Location: Sweden
Gender:
Age: 28

Post by Gurt » Mon Aug 06, 2018 3:48 pm

You could try to reinstall/repair all required software for the game to run properly. See https://mythologicinteractiveforums.com ... ?f=10&t=10.

If that doesn't help you need to provide a lot more details about how the black screen "keeps popping up every second".
You could also try to disable other third-party program that renders on top of other programs, like Steam, Fraps, OBS, perhaps other chat programs, GPU/CPU usage utility software, Skype etc... and see if that helps/interfere with SFD's Map Editor. Perhaps it works better on an alternative monitor if you have several.
0 x
Gurt

FutureWolf4
Meatbag
Posts: 4
Joined: Mon Aug 06, 2018 10:47 am

Post by FutureWolf4 » Mon Aug 06, 2018 4:19 pm

Gurt wrote:
Mon Aug 06, 2018 3:48 pm
You could try to reinstall/repair all required software for the game to run properly. See https://mythologicinteractiveforums.com ... ?f=10&t=10.

If that doesn't help you need to provide a lot more details about how the black screen "keeps popping up every second".
You could also try to disable other third-party program that renders on top of other programs, like Steam, Fraps, OBS, perhaps other chat programs, GPU/CPU usage utility software, Skype etc... and see if that helps/interfere with SFD's Map Editor. Perhaps it works better on an alternative monitor if you have several.
I recorded a couple of seconds of the map editor to show what the problem is, hopefully it answers your question (The recording software isn't the issue, I have the same problem even without the program on) : https://imgur.com/a/mvg3k1r
0 x

User avatar
Gurt
Lead Programmer
Lead Programmer
Posts: 1326
Joined: Sun Feb 28, 2016 3:22 pm
Title: Lead programmer
Started SFD: Made it!
Location: Sweden
Gender:
Age: 28

Post by Gurt » Mon Aug 06, 2018 4:43 pm

Does the problem start right away when you open the editor?
Does the problem persist after the list over objects have been updated with small icons? The small icons show up after some waiting.
Does the problem go away if you resize the editor view slightly?
0 x
Gurt

FutureWolf4
Meatbag
Posts: 4
Joined: Mon Aug 06, 2018 10:47 am

Post by FutureWolf4 » Mon Aug 06, 2018 4:46 pm

Gurt wrote:
Mon Aug 06, 2018 4:43 pm
Does the problem start right away when you open the editor?
Does the problem persist after the list over objects have been updated with small icons? The small icons show up after some waiting.
Does the problem go away if you resize the editor view slightly?
It is random when the problem starts, sometimes it will start right away and other times it takes a couple of seconds for it to begin.
The problem persists after the listing has been updated with small icons.
The problem doesn't go away when I resize the editor.
0 x

User avatar
Gurt
Lead Programmer
Lead Programmer
Posts: 1326
Joined: Sun Feb 28, 2016 3:22 pm
Title: Lead programmer
Started SFD: Made it!
Location: Sweden
Gender:
Age: 28

Post by Gurt » Mon Aug 06, 2018 4:52 pm

Then I have no clue what your specific problem is. Could be that the map editor is double buffered and somehow it doesn't work correctly with your specific computer, hardware and drivers. My last idea is that you should try toggling your VSYNC settings to on / off and see if it helps in the map editor.
0 x
Gurt

FutureWolf4
Meatbag
Posts: 4
Joined: Mon Aug 06, 2018 10:47 am

Post by FutureWolf4 » Mon Aug 06, 2018 5:02 pm

Sorry to say, VSYNC doesn't fix the problem. I guess my computer in question doesn't work properly with the map editor as you said. Thank you regardless for answering my question, have a nice day.
0 x

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest