Dear forum users! In compliance with the new European GDPR regulations, we'd just like to inform you that if you have an account, your email address is stored in our database. We do not share your information with third parties, and your email address and password are encrypted for security reasons.

New to the forum? Say hello in this topic! Also make sure to read the rules.

"Your selected language is out of date. Please update it."

Having trouble running SFD? This is the place to get help and report errors.
Forum rules
By using the forum you agree to the following rules. For this forum you also need to follow these additional rules.
Post Reply
User avatar
KliPeH
Moderator
Moderator
Posts: 814
Joined: Sat Mar 19, 2016 3:03 pm
Title: [happy moth noises]
SFD Account: KliPeH
Started SFD: Pre-Alpha 1.4.2
Gender:
Contact:

"Your selected language is out of date. Please update it."

Post by KliPeH » Thu Apr 04, 2019 7:29 pm

I have created a custom language pack for a texture pack currently in the making; the pack uses different weapon sprites so the pickup text had to be modified in accordance with that. At first I directly modified the Language_default.xml file found in the SFD directory, but the changes have been undone once the game has been updated.

The textures weren't lost since they have been placed inside the Documents directory (using the new texture application method). So, I figured I should create a Language_default.xml file in the Documents directory as well, that way I don't have to reapply the changes every time I update the game.

I have placed the modded Language_default.xml inside C:\ Users \ MY_NAME \ Documents \ Superfighters Deluxe \ Content \ Data \ Misc \ Language. I then went in-game and selected the new language pack from the setting menu. The game has notified me that some changes may not take effect immediately so I quit the game.

Now every time I open SFD I receive this little note at the bottom of the screen:
Image

The note appears for quite literally one single frame and then the game loads as it does usually. Every single bit of text I changed in-game appears perfectly fine, it's just that I see this bright yellow sentence every time I open my game (which I do a lot, testing each and every texture I make) and it's very mildly infuriating me.

How do I "update" my pack so this stops showing up every time I launch SFD?

EDIT: To clarify, the only language category I touched was "item.X". So for example, "Assault rifle" is now "M16A1", "Carbine" is "M1 Carbine" etc. I did not modify any other category.

I have kept the file named as "Language_default.xml", so maybe that's part of the issue?

EDIT #2: It was the issue. Solved!

EDIT #3: It was not the issue. I was bamboozled. The file name changed and it still appears in the language settings menu but the issue wasn't fixed. I still require assistance.
1 x
 
Image

User avatar
Gurt
Lead Programmer
Lead Programmer
Posts: 1593
Joined: Sun Feb 28, 2016 3:22 pm
Title: Lead programmer
Started SFD: Made it!
Location: Sweden
Gender:
Age: 29

Post by Gurt » Thu Apr 04, 2019 8:01 pm

Custom languages are entirely created using the included language tool. You can start it from the map editor under the "Tools" menu.

In the language tool do the following:
Select "New". Name your language anything you want (but maybe not "default").
After that you only modify the texts you want to modify and override from the default texts.
You should now have a few modified texts marked as "OK" and everything else as blank texts marked as "Text Missing".
Save your language file.
Restart SFD so it can properly read the newly created language file you created and select it in the settings. Restart again.
Now the texts modified in your language file will override the default texts.
0 x
Gurt

User avatar
KliPeH
Moderator
Moderator
Posts: 814
Joined: Sat Mar 19, 2016 3:03 pm
Title: [happy moth noises]
SFD Account: KliPeH
Started SFD: Pre-Alpha 1.4.2
Gender:
Contact:

Post by KliPeH » Thu Apr 04, 2019 10:11 pm

Gurt wrote:
Thu Apr 04, 2019 8:01 pm
Custom languages are entirely created using the included language tool. You can start it from the map editor under the "Tools" menu.

In the language tool do the following:
Select "New". Name your language anything you want (but maybe not "default").
After that you only modify the texts you want to modify and override from the default texts.
You should now have a few modified texts marked as "OK" and everything else as blank texts marked as "Text Missing".
Save your language file.
Restart SFD so it can properly read the newly created language file you created and select it in the settings. Restart again.
Now the texts modified in your language file will override the default texts.
I followed the instructions and modified the default file using the language tool. The new file looks different and does work but still shows me the brief error when the game loads. I want to point out that the modified texts were shown both times, with or without the tool, it's just the error that shows up that's bothering me.

EDIT: I have removed the modified language file and loaded the default one. The error now also shows up when I'm using the Default option. I have removed the file from the directory and verified the integrity of the game's files, which then redownloaded Language_default.xml. I still receive the error when launching SFD. Could the default file be damaged?

EDIT #2: Loading Language_default.xml with the language tool shows all the texts as "Out of date". That is probably the cause of the error, since my modified version relied on it. The error persists even after marking everything as "OK" and saving the file to the game's directory.
0 x
 
Image

User avatar
Gurt
Lead Programmer
Lead Programmer
Posts: 1593
Joined: Sun Feb 28, 2016 3:22 pm
Title: Lead programmer
Started SFD: Made it!
Location: Sweden
Gender:
Age: 29

Post by Gurt » Sat Apr 06, 2019 11:45 am

The text being shown for 1 frame is a bug and it's not supposed to be shown at all now. It's an older control logic checking that all texts are translated in your selected language file compared to the default one.

What the text means anyway is that the selected language has some untranslated texts or some old translated texts - buts it's OK.
We will just remove the warning entirely for the next update.

If the language file work for you in-game it's working as intended.
2 x
Gurt

Post Reply